Bug 5262

Summary: report signals as names, not numbers
Product: frysk Reporter: Andrew Cagney <cagney>
Component: generalAssignee: Andrew Cagney <cagney>
Status: RESOLVED FIXED    
Severity: normal    
Priority: P2    
Version: unspecified   
Target Milestone: ---   
Host: Target:
Build: Last reconfirmed:
Bug Depends on:    
Bug Blocks: 2246, 5292    

Description Andrew Cagney 2007-11-02 16:31:58 UTC
For instance, instead of:

Task 18068 is terminating from signal 11

report:

Task 18068 is terminating from signal 11 (SIGSEGV)

since signals vary between architectures, frysk.sys.Sig can't be used here. 
Instead a SignalFactory keyed of the ISA will need to be refered to.
Comment 1 Andrew Cagney 2007-11-02 16:33:05 UTC
Mark, you were curious :-)
Comment 2 Andrew Cagney 2008-02-22 16:06:15 UTC
Fixed some time ago
Comment 3 Andrew Cagney 2008-02-22 16:06:27 UTC
close