Bug 4394

Summary: testStepGoto(frysk.rt.TestStepping)junit.framework.AssertionFailedError
Product: frysk Reporter: Mike Cvet <mcvet>
Component: generalAssignee: Mike Cvet <mcvet>
Status: RESOLVED FIXED    
Severity: normal    
Priority: P2    
Version: unspecified   
Target Milestone: ---   
Host: Target:
Build: Last reconfirmed:
Bug Depends on: 4431    
Bug Blocks: 3346    

Description Mike Cvet 2007-04-18 18:54:47 UTC
1) testStepGoto(frysk.rt.TestStepping)junit.framework.AssertionFailedError: 
event loop run explictly stopped (Attempting to add observer)
   at frysk.proc.TestLib.assertRunUntilStop(TestRunner)
   at frysk.proc.TestLib.assertRunUntilStop(TestRunner)
   at frysk.rt.TestStepping.testStepGoto(TestRunner)
   at frysk.junit.Runner.runCases(TestRunner)
   at frysk.junit.Runner.runArchCases(TestRunner)
   at frysk.junit.Runner.runTestCases(TestRunner)
   at TestRunner.main(TestRunner)
Comment 1 Mike Cvet 2007-04-18 18:55:13 UTC
Appears to be random.
Comment 2 Mike Cvet 2007-04-24 16:30:00 UTC
This test times out because somehow TestRunner gets caught up in attempting to 
step a process which is not the actual test process. 

I grabbed some stack traces of the traced process, and ended up with varying 
results, including the following:

#0 0x00002aaaaaab1a2b in _dl_map_object_from_fd ()
#1 0x00002aaaaaab2d9c in _dl_map_object ()
#2 0x00002aaaaaab610d in openaux ()
#3 0x00002aaaaaab7d26 in _dl_catch_error ()
#4 0x00002aaaaaab67d6 in _dl_map_object_deps ()
#5 0x00002aaaaaaae306 in dl_main ()
#6 0x00002aaaaaabde0b in _dl_sysdep_start ()
#7 0x00002aaaaaaac468 in _dl_start ()
#8 0x00002aaaaaaabb58 in [unknown]

or

#0 0x00002aaaaaabeff6 in strcmp ()
#1 0x00002aaaaaab3c87 in check_match.8134 ()
#2 0x00002aaaaaab4084 in do_lookup_x ()
#3 0x00002aaaaaab4282 in _dl_lookup_symbol_x ()
#4 0x00002aaaaaab57a5 in _dl_relocate_object ()
#5 0x00002aaaaaaae77a in dl_main ()
#6 0x00002aaaaaabde0b in _dl_sysdep_start ()
#7 0x00002aaaaaaac468 in _dl_start ()
#8 0x00002aaaaaaabb58 in [unknown]

or 

#0 0x00002aaaaaab7bc3 in _dl_fixup ()
#1 0x00002aaaaaabd3a2 in _dl_runtime_resolve ()
#2 0x00002aaaaaccb628 in __pthread_initialize_minimal ()
#3 0x00002aaaaaccaf29 in _init ()

or just plain:

#0 0x00002aaaaaabeff4 in [unknown]
Comment 3 Mike Cvet 2007-04-24 16:31:51 UTC
Occasionally it may just get lost in the TaskState state machine, never 
returning to the SteppingEngine observer.
Comment 4 Mike Cvet 2007-04-26 16:29:30 UTC
Tracing problem moved to #4431
Comment 5 Mike Cvet 2007-07-27 17:12:33 UTC
Fixed with latest version of TestStepping