Bug 3920

Summary: Merge all three "process pickers" into a single one, in the Druid
Product: frysk Reporter: Mike Cvet <mcvet>
Component: generalAssignee: Mike Cvet <mcvet>
Status: RESOLVED FIXED    
Severity: enhancement CC: swagiaal
Priority: P2    
Version: unspecified   
Target Milestone: ---   
Host: Target:
Build: Last reconfirmed:
Bug Depends on: 3978    
Bug Blocks: 1632, 1633    

Description Mike Cvet 2007-01-25 21:19:02 UTC
Including having more information, such as memory usage.
Comment 1 Mike Cvet 2007-02-06 16:53:36 UTC
Log message:
	frysk-gui/frysk/gui/monitor:
	2007-02-06  Mike Cvet  <mcvet@redhat.com>
	
	* ListView.java (debugProcessObserver): Added.
	(init): Initialize above object.
	(addDP): Added. Specializes in adding DebugProcesses.
	(addDP): Overloaded method. Specializes in storing useful GuiProc
	specific information.
	(addDP): Ditto.
	(remove): Attempt to delete debugProcessObserver from the incoming
	GuiObject.
	(watchGuiProcs): Added. Watches a special list containing GuiProcs,
	so that their useful information can be used.
	(DebugProcessObserver): Added. Updates when DebugProcess events
	occur.
	* ProcWiseDataModel.java (childCountDC): Removed.
	(pidDC): Added.
	(vszDC): Ditto.
	(rssDC): Ditto.
	(timeDC): Ditto.
	(stat): Ditto.
	(iterMap): Refactored from iterHash, changed to HashMap.
	(ProcWiseDataModel): Initialize new DataColumns and Stat.
	Fixes #3920.
	(setRow): Removed.
	(collectProcs): Added. Adds processes matching a name string into
	a LinkedList.
	(searchAllNames): Added. Returns a new LinkedList containing processes
	of the same name contained in the model.
	(searchPid): Finds a process matching PID parameter in the model.
	(setSelected): Removed tree child specific code.
	(ProcCreatedObserver.update): Removed process group code, added new
	stat code.
	(ProcDestroyedObserver): Removed tree child code.
	(getNameDC): Added.
	(getLocationDC): Ditto.
	(getPIDDC): Ditto.
	(getVszDC): Ditto.
	(getRssDC): Ditto.
	(getTimeDC): Ditto.
	(getObjectDC): Ditto.
	(getSelectedDC): Ditto.
	* ProcWiseTreeView.java (dataModel): Changed from psDataModel.
	(treeStore): Added.
	(pwtvTVC): Added. TreeViewColumn array.
	(ProcWiseTreeView): Set global TreeModel to parameter.
	(mountDataModel): Set new column properties, append them to this
	TreeView. Fixed up the TreeModelFilter.
	(setUpColumns): Added. Initializes all columns, sets all their
	information, sets properties such as sorting.
	* SessionProcDataModel.java (addProc): Removed redundant try
	statement.
	(ProcTasksObserver): Removed.
	(removeProc): Removed.
	(TaskDestroyedObserver): Removed.
	(getThreadCount): Removed.
	
	frysk-gui/frysk/gui:
	2007-02-06  Mike Cvet  <mcvet@redhat.com>
	
	* SessionManagerGui.java (previousSession): Removed.
	(debugSingleProcess): Ditto.
	(debugSingleProcessAction): Ditto.
	(processPicker): Ditto.
	(getDebugSingleProcess): Ditto.
	(setButtonStates): Removed references to debugging state.
	(getSessionManagementControls): Removed references to RadioButtons.
	(openSession): No longer initializes a ProcessPicker, builds a Terminal,
	or handles popup windows. Hands the selected process to the druid. Fixes
	#3978, #3921.
	* druid/CreateFryskSessionDruid.java (debugButton): Added.
	(loadSession): Ditto.
	(setNewSession): Make sure to enable 'quick debug' button. Fixes #3922.
	(setEditSessionMode): Collects all DebugProcesses and Observers from
	saved session; add all currently-running processes of the same name as
	saved processes to the current session. Also add all saved observers to
	all DebugProcesses.
	(loadSessionMode): Added. Functionally similar to setEditSessionMode(),
	makes safe assumptions about saved process and observer combinations.
	Linked directly to the monitor window. Fixes #3978.
	(filterDataInSession): Re-arranged to work with the elimination of
	generic process groups.
	(setTreeSelected): Removed redundant parameter.
	(addProcessParent): Cleaned up.
	(changeGroupState): Removed two of three scenarios due to the 
elimination
	of process groups. Extensively cleaned up to work with new 
implementation.
	(setProcessNext): Made aware that the druid now loads sessions as well.
	(getProcessSelectionControls): Removed references to process groups. 
Tells
	the ListView to watch GuiProcs instead of DebugProcesses. Null checks,
	fixes #3931. Search for specific processes using PIDs.
	(getProcessObserverControls): Tells the ListView to watch GuiProcs 
instead
	of DebugProcesses.
	(getDruidStructureControls): Added code for debugging button. The finish
	button now sets up the terminal and session for the monitor window.
	(attachLinkedListsToWidgets): Watch GuiProcs instead of DebugProcesses.
	(setUpCurrentPage): Set next button sensitive with page 0, fixes button 
bug.
	* gladedir/frysk_create_session_druid.glade: Resized, added button for
	launching the SourceWindow.
	* gladedir/frysk_session_manager.glade: Removed radio buttons and
	SourceWindow launch button.
	* sessions/DebugProcess.java (addObservers): Iterate through the 'procs'
	LinkedList rather than 'allProcsList' to add the observers.
	* sessions/Session.java: Applied GNU formatting.
	(clearProcesses): Added. Removes all DebugProcesses from the global 
list.
	* sessions/SessionManager.java: Applied GNU formatting.