Bug 3873

Summary: TestLib.isChildOf() to use Stat.ppid rather than proc.getParent().getPid()
Product: frysk Reporter: Nurdin Premji <npremji>
Component: generalAssignee: Nurdin Premji <npremji>
Status: RESOLVED FIXED    
Severity: normal    
Priority: P2    
Version: unspecified   
Target Milestone: ---   
Host: Target:
Build: Last reconfirmed:
Bug Depends on:    
Bug Blocks: 3539    
Attachments: Log file of testProcBlockExec(frysk.proc.TestExec)

Description Nurdin Premji 2007-01-15 19:52:20 UTC
Trying to switch over isChildOf to use Stat.ppid rather than using
proc.getParent().getPid() so that getProc interface can be used (an even more
optimized interface than findProc).

The problem is some testcases have problems with this new implementation as
sometimes the ppid returned from Stat is 0. I think this means that the process
is a zombie but I'm not sure. The Stat.state character returns ^@ instead of 'Z'.

Code:
    static public boolean isChildOf (int pid, Proc proc)
    {
      logger.log(Level.FINE, "isChildOf pid: {0} proc: {1}\n", 
                 new Object[] {new Integer(pid), proc});
	// Process 1 has no parent so can't be a child of mine.
	if (proc.getPid () == 1)
      {
        logger.log(Level.FINE, "isChildOf proc is init\n");
	    return false;
      }
	// If the parent's pid matches this processes pid, assume that
	// is sufficient.  Would need a very very long running system
	// for that to not be the case.        
    
    Stat stat = new Stat();
    stat.refresh(proc.id.id);
    
	if (stat.ppid == pid)
      {
        logger.log(Level.FINE, "isChildOf proc is child\n");
	    return true;
      }
    logger.log(Level.FINE, "isChildOf proc {3} not child pid: {0} ppid: {1}
parent: {2}\n",
               new Object[] {new Integer(pid), new Integer(stat.ppid),
proc.getParent(), proc});
    
    logger.log(Level.FINE, "isChildOf status{0}\n", new Character(stat.state));
	return false;
    }

Log to follow.
Comment 1 Nurdin Premji 2007-01-15 19:53:51 UTC
Created attachment 1497 [details]
Log file of testProcBlockExec(frysk.proc.TestExec)
Comment 2 Nurdin Premji 2007-01-23 17:52:40 UTC
Fixed, some test cases were using an out of date parent to check if the test process was started by frysk. Since these test processes later became daemons, the method of using isChildOfMine as an eventLoop stopping criteria were invalid. These were changed to use the specific pid of the task to stop the eventLoop.