Bug 3454

Summary: Build system too liberal in finding main functions in java classes.
Product: frysk Reporter: Nurdin Premji <npremji>
Component: generalAssignee: Nurdin Premji <npremji>
Status: RESOLVED FIXED    
Severity: normal CC: mcvet, pmuldoon
Priority: P2    
Version: unspecified   
Target Milestone: ---   
Host: Target:
Build: Last reconfirmed:
Bug Depends on:    
Bug Blocks: 2235    

Description Nurdin Premji 2006-11-03 15:49:39 UTC
The build system classifies classes that do not have main functions as
executable classes if they have the word main anywhere in the file. For example
inside a quote or comments.
Comment 1 Nurdin Premji 2006-11-03 15:50:34 UTC
Fixed

2 Nov 2006 
   common/CL
        
        * Makefile.gen.sh (has_main): Use jv-scan to find java files with
        main functions rather than grep.
Comment 2 Nurdin Premji 2006-11-03 16:20:45 UTC
No really fixed
Comment 3 Andrew Cagney 2006-11-21 21:35:39 UTC
*** Bug 3448 has been marked as a duplicate of this bug. ***