Bug 3204

Summary: Wrong Syscall information in EventViewer on FC5 ppc64
Product: frysk Reporter: Yao Qi <qiyaoltc>
Component: generalAssignee: Yao Qi <qiyaoltc>
Status: RESOLVED FIXED    
Severity: normal CC: mcvet, pmuldoon, woodzltc, zhengyzy
Priority: P2    
Version: unspecified   
Target Milestone: ---   
Host: powerpc64-redhat-linux-gnu Target:
Build: Last reconfirmed:
Bug Depends on:    
Bug Blocks: 2188    

Description Yao Qi 2006-09-14 10:06:43 UTC
fire frysk and add Syscall Observer to some program, such as "bash", and enter
some command in this shell.
These events could be found in window "Main Log"

Thu Sep 14 09:44:49 CST 2006 Syscall Observer: PID: 32376 TID: 32376 Event:
Entering Syscall - <0> Host: plinuxt18.cn.ibm.com
Thu Sep 14 09:44:55 CST 2006 Syscall Observer: PID: 2535 TID: 2535 Event:
Entering Syscall - <0> Host: plinuxt18.cn.ibm.com
Thu Sep 14 09:44:58 CST 2006 Syscall Observer: PID: 1695 TID: 1695 Event:
Entering Syscall - <0> Host: plinuxt18.cn.ibm.com
Thu Sep 14 09:45:00 CST 2006 Syscall Observer PID: 2535 TID: 2535 Event: LThu
Sep 14 09:51:13 CST 2006 Syscall Observer PID: 2535 TID: 2535 Event: Leaving
Syscall -  <0> returns with value -1 ERRNO=858240 Host: plinuxt18.cn.ibm.com
Thu Sep 14 09:51:13 CST 2006 Syscall Observer: PID: 2535 TID: 2535 Event:
Entering Syscall - <0> Host: plinuxt18.cn.ibm.com
Thu Sep 14 09:51:13 CST 2006 Syscall Observer PID: 2535 TID: 2535 Event: Leaving
Syscall -  <0> returns with value -1 ERRNO=858576 Host: plinuxt18.cn.ibm.com
Thu Sep 14 09:51:13 CST 2006 Syscall Observer: PID: 2535 TID: 2535 Event:
Entering Syscall - <0> Host: plinuxt18.cn.ibm.com
Thu Sep 14 09:51:13 CST 2006 Syscall Observer PID: 2535 TID: 2535 Event: Leaving
Syscall -  <0> returns with value -1 ERRNO=858496 Host: plinuxt18.cn.ibm.com
Thu Sep 14 09:51:13 CST 2006 Syscall Observer: PID: 2535 TID: 2535 Event:
Entering Syscall - <0> Host: plinuxt18.cn.ibm.com


The output is the same as we run ftrace on ppc64 to a 32-bit program.  This
problem may be caused by bi-arch support.
Comment 1 Yao Qi 2006-10-19 07:44:42 UTC
2006-10-10  Yao Qi  <qiyaoltc@cn.ibm.com>

        * IsaFactory.java: Return a LinuxPPC32On64 object in a bi-arch
        condition.

        * LinuxPPC32On64.java: New file.

        * TestRegs.java: Add bi-arch test for ppc64.

        * LinuxPPC.java: Add licence header.
        * LinuxPPC64.java: Likewise.

        * IsaPPC.java: Merge registerMap to its parent.

And run frysk on FC5, and get the output from MainLog as follows,

Thu Oct 19 19:38:05 CST 2006 Syscall Observer: PID: 31267 TID: 31267 Event:
Entering Syscall - waitpid (-1,0xff97077c,10) Host: power-frysk1.cn.ibm.com
Thu Oct 19 19:38:05 CST 2006 Syscall Observer: PID: 29770 TID: 29770 Event:
Entering Syscall - read (0,0xffee7f0f,1) Host: power-frysk1.cn.ibm.com
Thu Oct 19 19:38:05 CST 2006 Syscall Observer: PID: 29809 TID: 29809 Event:
Entering Syscall - read (0,0xffbe8e9f,1) Host: power-frysk1.cn.ibm.com
Thu Oct 19 19:38:05 CST 2006 Syscall Observer: PID: 31138 TID: 31138 Event:
Entering Syscall - read (0,0xffa39e9f,1) Host: power-frysk1.cn.ibm.com

Close this bug!