Bug 3099

Summary: omit tests from TestRunner
Product: frysk Reporter: Stepan Kasal <skasal>
Component: generalAssignee: Chris Moller <cmoller>
Status: RESOLVED FIXED    
Severity: normal CC: mark, qiyaoltc
Priority: P2    
Version: unspecified   
Target Milestone: ---   
Host: Target:
Build: Last reconfirmed:
Bug Depends on:    
Bug Blocks: 3005, 3012, 3066    

Description Stepan Kasal 2006-08-21 16:58:38 UTC
Test Runner should recognize command-line parameters/options which would switch
off named JUnit tests.

It is common that a package is built in a chrooted environment on a different
system from the one which will be used on the installed system.
For example, this happens on Fedora with mock.

If the kernel of the build machine is not ready for frysk, some of the JUnit
tests will fail. We need a way to disable them during `make check' but leave
them for the `funit' run on installed system. Since the problem is distribution
dependent, it seems adequate to switch the tests off in the distribution package
definition: for example, on Fedora this means in the frysk.spec file.

To be able to do that, we need a way to tell TestRunner to omit listed tests.

I think this means TestRunner should accept command-line parametrs to that effect.
Comment 1 Andrew Cagney 2006-12-07 18:18:39 UTC
--exclude and --include options added