Bug 2707

Summary: testExport(frysk.gui.test.TestObserverSaveLoad)junit.framework.AssertionFailedError: Number of Observers expected:<1> but was:<0>
Product: frysk Reporter: Andrew Cagney <cagney>
Component: generalAssignee: Sami Wagiaalla <swagiaal>
Status: RESOLVED FIXED    
Severity: normal CC: qiyaoltc
Priority: P1    
Version: unspecified   
Target Milestone: ---   
Host: Target:
Build: Last reconfirmed:
Bug Depends on:    
Bug Blocks: 1987    

Description Andrew Cagney 2006-05-30 06:35:04 UTC
1)
testExport(frysk.gui.test.TestObserverSaveLoad)junit.framework.AssertionFailedError:
Number of Observers expected:<1> but was:<0>
   at frysk.gui.test.TestObserverSaveLoad.testExport (TestRunner)
   at java.lang.reflect.Method.invoke (libgcj.so.7)
   at frysk.junit.Runner.<init> (TestRunner)
   at TestRunner.main (TestRunner)
Comment 1 Sami Wagiaalla 2006-06-15 21:42:26 UTC
2006-06-15  Sami Wagiaalla  <swagiaal@redhat.com>

	* observers/ObserverManager.java: added loadObservers()
	to init instead of it having to be called expelictly fix for (2707).
	Added log statements.
	Added check for existing observers with the same name as
	observer being loaded, and code to update them if thats the
	case.

Comment 2 Sami Wagiaalla 2006-06-19 16:56:44 UTC
*** Bug 2713 has been marked as a duplicate of this bug. ***