Bug 2688

Summary: frysk aborts if "Cancel" then "Finish" is clicked
Product: frysk Reporter: Rick Moseley <rmoseley>
Component: generalAssignee: Sami Wagiaalla <swagiaal>
Status: RESOLVED FIXED    
Severity: normal CC: pmuldoon
Priority: P2    
Version: unspecified   
Target Milestone: ---   
Host: Target:
Build: Last reconfirmed:
Bug Depends on:    
Bug Blocks: 3401    
Attachments: Fix for cancel-finish abort

Description Rick Moseley 2006-05-23 18:23:50 UTC
If you just try to dismiss the druid window without entering any session name
and just click on "Cancel" and "Finish".  When you click "Cancel" the following
message appears several times:

(java-gnome:4758): Pango-WARNING **: Invalid UTF-8 string passed to
pango_layout_set_text()


When the "Finish" button is clicked this traceback is output:

java.lang.RuntimeException: The given item name[NoName] is already used
   at frysk.gui.monitor.UniqueHashMap.add (FryskGui)
   at frysk.gui.sessions.SessionManager.addSession (FryskGui)
   at frysk.gui.druid.CreateFryskSessionDruid$17.buttonEvent (FryskGui)
   at org.gnu.gtk.Button.fireButtonEvent (libgtkjava-2.8.so)
   at org.gnu.gtk.Button.handleClick (libgtkjava-2.8.so)
   at org.gnu.gtk.Gtk.gtk_main (libgtkjava-2.8.so)
   at org.gnu.gtk.Gtk.main (libgtkjava-2.8.so)
   at frysk.gui.Gui.gui (FryskGui)
   at frysk.gui.FryskGui.main (FryskGui)
Comment 1 Mike Cvet 2006-05-31 14:33:50 UTC
Created attachment 1058 [details]
Fix for cancel-finish abort

The ButtonListener for cancelButton declared currentSession as a new Session(),
and by default saving a session as "NoName". However, since the user is
cancelling  this current session, it should not be saved.
Comment 2 Sami Wagiaalla 2006-05-31 15:08:33 UTC
commited... thanx mike