Bug 2685

Summary: need to skip probes on insufficient stack
Product: systemtap Reporter: Frank Ch. Eigler <fche>
Component: translatorAssignee: Frank Ch. Eigler <fche>
Status: RESOLVED FIXED    
Severity: normal    
Priority: P2    
Version: unspecified   
Target Milestone: ---   
Host: Target:
Build: Last reconfirmed:

Description Frank Ch. Eigler 2006-05-22 18:19:41 UTC
Similarly to bug #2185, because we don't have a separate stack for kprobe
handling (bug #931), we may have stack exhaustion problems in ordinary usage
without reentrancy.  We go out of our way to minimize stack usage, but we need to
- estimate or measure stack usage of a worst-case scenario (kprobes handler,
deeply nested systemtap expression, calling into the most complex runtime routine)
- add code to the probe entry functions to check for available stack space, and
punt (skip probe) if it's not sufficient
Comment 1 Frank Ch. Eigler 2006-11-26 23:28:56 UTC
patch committed.  The default MINSTACKSPACE may need to be tuned in the future.