Bug 23559

Summary: stapbpf string literal support for octal and hex escape codes
Product: systemtap Reporter: Serhei Makarov <me>
Component: bpfAssignee: Serhei Makarov <me>
Status: CLOSED FIXED    
Severity: normal CC: wcohen
Priority: P2    
Version: unspecified   
Target Milestone: ---   
Host: Target:
Build: Last reconfirmed:
Bug Depends on: 22330    
Bug Blocks:    

Description Serhei Makarov 2018-08-21 21:21:15 UTC
I've written a patch for this. But currently, it's not enabled because putting arbitrary non-printing characters into the trace_printk() buffer seems to be a good recipe for chaos.

So this issue also depends on PR22330.
Comment 1 Serhei Makarov 2019-06-18 16:47:36 UTC
Committed a patch which allows all non-printing characters except '\0' (which is dropped silently). This allows ansi_colors examples to work with stapbpf.

Closing this PR, will open new ones if any edge cases come up.
Comment 2 William Cohen 2019-06-18 17:00:58 UTC
Commit 9f888f1630cce8527f14d93d8b638952e4c45f71 seems to work fine for the ansi_colors and ansi_colors2 examples and they now work with the bpf backend.