Bug 22174

Summary: memory allocation failure in objalloc.c (_objalloc_alloc)
Product: binutils Reporter: Agostino Sarubbo <ago>
Component: binutilsAssignee: Not yet assigned to anyone <unassigned>
Status: RESOLVED DUPLICATE    
Severity: normal CC: amodra
Priority: P2    
Version: 2.30   
Target Milestone: ---   
Host: Target:
Build: Last reconfirmed:
Attachments: stacktrace
testcase

Description Agostino Sarubbo 2017-09-21 13:38:04 UTC
Created attachment 10450 [details]
stacktrace

NOTE: it may be a false positive

On master compiled today.
# nm -V
GNU nm (Gentoo git) 2.29.51.20170921


Command to reproduce:
# nm -A -a -l -S -s --special-syms --synthetic --with-symbol-versions -D $FILE
Comment 1 Agostino Sarubbo 2017-09-21 13:38:29 UTC
Created attachment 10451 [details]
testcase
Comment 2 Alan Modra 2017-09-23 08:45:27 UTC
Same underlying problem as pr22166

*** This bug has been marked as a duplicate of bug 22166 ***