Bug 2067

Summary: investigate whether/how module("foo").* for compiled-in foo
Product: systemtap Reporter: Frank Ch. Eigler <fche>
Component: translatorAssignee: Unassigned <systemtap>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: P2    
Version: unspecified   
Target Milestone: ---   
Host: Target:
Build: Last reconfirmed:

Description Frank Ch. Eigler 2005-12-19 18:24:39 UTC
According to one report, they don't currently work.

One possibility is to export the CONFIG_* values to systemtap scripts as yet
another preprocessor predicate, so that a cunning user could use kernel. instead
of module("foo"). (assuming that even works.  A better way would be to make the
translator/elfutils understand module("foo") for both cases.
Comment 1 Roland McGrath 2005-12-19 21:02:01 UTC
In the kernel build process, each module is drawn from a subdirectory in the
source tree.  So one possibility is to define module-name matching to mean a
name wildcard on the CU name, which is the source file.
Comment 2 Frank Ch. Eigler 2007-10-15 19:45:56 UTC
explicit alternation is a good implementation tactic

*** This bug has been marked as a duplicate of 3887 ***