Bug 1888

Summary: gcj: no input files
Product: frysk Reporter: Andrew Cagney <cagney>
Component: generalAssignee: Rick Moseley <rmoseley>
Status: RESOLVED FIXED    
Severity: normal CC: scox
Priority: P1    
Version: unspecified   
Target Milestone: ---   
Host: Target:
Build: Last reconfirmed:
Bug Depends on:    
Bug Blocks: 2235    

Description Andrew Cagney 2005-11-18 20:13:38 UTC
I think the makefile has a problem when built ``out-of-tree''.

scox	<wonder how stan's going with the -log option> I just need to have it
create a proper ~/.frysk/logging.properties, but I'm getting build
errors...make[2]: Entering directory
`/home/scox/frysk/bld/linux/frysk-imports/cdtparser'gcj -C -g -O2
	scox	gcj: no input files

I've disabled it for now.
Comment 1 Stan Cox 2005-11-21 03:53:51 UTC
This patch gets cdtparser to build, but the final step to produce cdtparser.o
fails as follows.  
gcj -I/home/scox/frysk/src/frysk-imports -I. -Ijargs.jar -Ijunit.jar -Werror
-Wall -fPIC  -g -O -fjni -c cdtparser.jar
org/eclipse/cdt/core/parser/ParserFactoryError.java:0: error: cannot find file
for class org.eclipse.cdt.core.parser.ParserFactoryError$Kind
org/eclipse/cdt/core/parser/ParserFactoryError.java:41: error: cannot find file
for class org.eclipse.cdt.core.parser.ParserFactoryError$Kind
org/eclipse/cdt/core/parser/ParserFactoryError.java:41: error: cannot find file
for class org.eclipse.cdt.core.parser.ParserFactoryError$Kind
org/eclipse/cdt/core/parser/ast/IASTParameterReference.java:0: error: cannot
find file for class org.eclipse.cdt.core.parser.ast.IASTReference
org/eclipse/cdt/core/parser/ast/IASTParameterReference.java:0: error: cannot
find file for class org.eclipse.cdt.core.parser.ast.IASTReference
org/eclipse/cdt/core/parser/ast/IASTParameterReference.java:0: confused by
earlier errors, bailing out

I tried adding -findirect-dispatch, but I get a SIGSEGV.

Here is the patch to get cdtparser.jar to build.  I switched to ecj, because I
got an error compiling a couple of files using gcj -C
Index: cdtparser/Makefile.am
===================================================================
RCS file: /cvs/frysk/frysk-imports/cdtparser/Makefile.am,v
retrieving revision 1.1
diff -u -r1.1 Makefile.am
--- cdtparser/Makefile.am       16 Nov 2005 20:38:53 -0000      1.1
+++ cdtparser/Makefile.am       21 Nov 2005 03:40:13 -0000
@@ -37,26 +37,20 @@
 # version and license this file solely under the GPL without
 # exception.

-CLEANFILES =
-
 # The target we want to build.
 noinst_DATA = cdtparser.jar

 # Make a jar file.
-cdtparser.jar: stamp
-               find * -name '*.class' -print | fastjar -@ -cf $@
-
-stamp: $(sources)
-       $(GCJ) -C -g -O2 $(sources)
+cdtparser.jar: $(CLASSES)
+       find $(srcdir) -name '*.class' | fastjar -@ -cf $@

-sources = $(shell find . -name '*.java')
-clean = $(shell find . -name '*.class' -exec rm {} \;)
+# %.class : %.java; $(GCJ) -I$(srcdir) -C -g -O2 $<
+%.class : %.java; $(JAVAC) -classpath $(srcdir) $<

-CLEANFILES += $(clean)
+SOURCES = $(shell find $(srcdir) -name '*.java')
+CLASSES = $(shell find $(srcdir) -name '*.java' | sed 's/java/class/')
+CLEANFILES = $(shell find $(srcdir) -name '*.class')

 clean-local:
+       @for i in $(CLEANFILES); do rm -f $$i ; done
        -rm cdtparser.jar
Comment 2 Rick Moseley 2005-11-21 21:26:13 UTC
Fixed in current version in the HEAD in the cvs repo.
Comment 3 Rick Moseley 2005-11-21 22:20:25 UTC
Not realyy fixed for "out of tree builds".
Comment 4 Rick Moseley 2005-11-22 19:50:55 UTC
Closed thanks to a final push by Andrew to get it to built "out of tree".