Bug 1801

Summary: expression evaluator
Product: frysk Reporter: Tarun Khanna <tkhanna>
Component: generalAssignee: Stan Cox <scox>
Status: RESOLVED DUPLICATE    
Severity: normal CC: cagney
Priority: P1    
Version: unspecified   
Target Milestone: ---   
Host: Target:
Build: Last reconfirmed:
Bug Depends on:    
Bug Blocks: 3391    

Description Tarun Khanna 2005-11-03 20:58:52 UTC
The expressino evaluator does not handle the following

- arrays
- objects (classes, structs, enums etc..)
- type casting
Comment 1 Stan Cox 2006-12-22 16:06:50 UTC
Support is partially there now:

(fhpd) print (float)1
1.0
(fhpd) print arr_1
[0]=1[1]=2[2]=3[3]=4[4]=5[5]=6[6]=7[7]=8[8]=9[9]=0[10]=1[11]=2[12]=3[13]=4[14]=5[15]=6[16]=7[17]=8[18]=9[19]=0[20]=1[21]=2[22]=3[23]=4[24]=5[25]=6[26]=7[27]=8[28]=9[29]=0[30]=1[31]=2
(fhpd) print class_1
class_double_1=12.34,class_int_2=15.0,
Comment 2 Stan Cox 2008-04-23 20:52:10 UTC

*** This bug has been marked as a duplicate of 1726 ***