Bug 1584

Summary: Validate RPM requirements
Product: frysk Reporter: Igor Foox <ifoox>
Component: generalAssignee: Igor Foox <ifoox>
Status: RESOLVED FIXED    
Severity: normal    
Priority: P1    
Version: unspecified   
Target Milestone: ---   
Host: Target:
Build: Last reconfirmed:
Bug Depends on:    
Bug Blocks: 1465    

Description Igor Foox 2005-10-28 18:50:11 UTC
We need to validate that all the Requires and BuildRequires clauses in the RPM
spec are actually needed and none are missing. Also check that the build system
checks for everything we need for build.
Comment 1 Igor Foox 2005-10-28 18:50:35 UTC
Apparently javac is not being checked for by the build system.
Comment 2 Igor Foox 2005-10-28 19:03:50 UTC
We had xfig as a requirement, apparently we only need transfig (which provides
fig2dev). 
Build system doesn't check for fig2dev either.
Comment 3 Igor Foox 2005-10-28 19:27:35 UTC
Validated built-time requirements as following:
* frysk-cdtparser (needs to be changed to cdt-parser)
* junit 
* antlr 
* transfig 
* jdom 
* libgtk-java-devel 
* libglade-java-devel 
* cairo-java-devel 
* cairo-devel 
* gtk2-devel 
* libvte-java-devel 
* vte-devel 
* java-1.4.2-gcj-compat-devel
Comment 4 Igor Foox 2005-10-28 19:39:23 UTC
Verified the runtime dependencies as:
* libgtk-java
* libglade-java
* libvte-java
And for some weird reason:
* frysk-cdtparser.jar.so.

I'm not sure why the last one appears, since it gets compiled like any other
file. Maybe it's because the so actually gets compiled by rpm, unlike jdom or
antlr, which are handled by the build system. This should get resolved with
http://sourceware.org/bugzilla/show_bug.cgi?id=1585 .