Bug 1550

Summary: add Proc.getExecutablePath()
Product: frysk Reporter: Sami Wagiaalla <swagiaal>
Component: generalAssignee: Andrew Cagney <cagney>
Status: RESOLVED FIXED    
Severity: normal CC: cagney, pmuldoon, swagiaal
Priority: P1    
Version: unspecified   
Target Milestone: ---   
Host: Target:
Build: Last reconfirmed:
Bug Depends on: 2106    
Bug Blocks: 1586, 1593, 1651, 1652, 1654    

Description Sami Wagiaalla 2005-10-26 15:15:05 UTC
this will be required for program observables to check
if the event came from the same executable the user 
specified
Comment 1 Sami Wagiaalla 2005-10-28 16:35:10 UTC
It should be noted that processies wich represent scripts
/proc/$$/exe points to the script engine... exe /bin/bash
Comment 2 Andrew Cagney 2006-01-07 19:34:50 UTC
Index: frysk-core/frysk/proc/ChangeLog
2006-01-07  Andrew Cagney  <cagney@redhat.com>

        * LinuxProc.java (sendrecExe()): Add.
        * TestProcGet.java (testGetExe()): Add.
        * Proc.java (exe, sendrecExe(), getExe()): Add.

Index: frysk-sys/frysk/sys/proc/ChangeLog
2006-01-07  Andrew Cagney  <cagney@redhat.com>

        * cni/Exe.cxx: New.
        * Exe.java: New.

java.io.File(String).getCanonicalPath() proves useful!
Comment 3 Andrew Cagney 2006-01-07 19:36:31 UTC
*** Bug 2106 has been marked as a duplicate of this bug. ***