Bug 10588

Summary: The handle command should accept user defined commands after 'stop'
Product: gdb Reporter: Joseph Garvin <k04jg02>
Component: breakpointsAssignee: Not yet assigned to anyone <unassigned>
Status: RESOLVED DUPLICATE    
Severity: enhancement CC: gdb-prs
Priority: P2    
Version: 6.8   
Target Milestone: 6.8   
Host: Target:
Build: Last reconfirmed:

Description Joseph Garvin 2009-09-02 14:45:19 IST
It'd be nice if you could create a command using 'define' and then use 'handle'
to specify that when a signal is given you want execution to pause *and* execute
your command. This can be useful for diagnosing time sensitive bugs (my command
might include some 'shell sleep' calls) or GUIs where you don't want to move
your mouse back to the terminal window because it'll trigger more X events.
Comment 1 Tom Tromey 2009-09-02 15:29:40 IST
I'm closing this as a dup; I think it is a restatement of the
"catch signal" idea.

*** This bug has been marked as a duplicate of 7221 ***