[COMMITTED] config: Add an explicit Requires elfutils-debuginfod-client for debuginfod.

Mark Wielaard mark@klomp.org
Thu Nov 28 15:21:00 GMT 2019


elfutils-debuginfod depends indirectly already on the client library.
Make that explicit so they are always updated in sync. Which isn't
technically required, but makes things clearer and simpler on updates.

Signed-off-by: Mark Wielaard <mark@klomp.org>
---
 config/ChangeLog        | 5 +++++
 config/elfutils.spec.in | 1 +
 2 files changed, 6 insertions(+)

diff --git a/config/ChangeLog b/config/ChangeLog
index 4e481bcc..d71fb391 100644
--- a/config/ChangeLog
+++ b/config/ChangeLog
@@ -1,3 +1,8 @@
+2019-11-28  Mark Wielaard  <mark@klomp.org>
+
+	* elfutils.spec.in (debuginfod): Add an explicit Requires
+	elfutils-debuginfod-client.
+
 2019-11-27  Mark Wielaard  <mark@klomp.org>
 
 	* elfutils.spec.in: Move all versioned libdebuginfod libraries
diff --git a/config/elfutils.spec.in b/config/elfutils.spec.in
index 8358137d..1cdca215 100644
--- a/config/elfutils.spec.in
+++ b/config/elfutils.spec.in
@@ -148,6 +148,7 @@ License: GPLv2+ or LGPLv3+
 %package debuginfod
 Summary: HTTP ELF/DWARF file server addressed by build-id
 License: GPLv3+
+Requires: elfutils-debuginfod-client = %{version}-%{release}
 BuildRequires: systemd
 Requires(post):   systemd
 Requires(preun):  systemd
-- 
2.18.1



More information about the Elfutils-devel mailing list