This is the mail archive of the mailing list for the pthreas-win32 project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Pthread_join waits endlessly for already ended thread

I'm looking for possible bugs in the library that might explain this. For example, pthread_join() relies on the underlying Win32 thread handle close being signalled and I don't think this is occurring in all cases. Replacing this with a dedicated event may be a better way to go.

Re cleanup styles in general, just make sure your code and the pthreads library are built using the same cleanup style. If you run against the pthreadVCE2.dll then you must build your code with __CLEANUP_CXX defined. If no style is defined then __CLEANUP_C is used by default (assuming pthreadVC2.dll). But AFAICS this shouldn't cause the longjmp() hang issue which is internal to the library. Unless you have a specific need, use pthreadVC2.dll.

Also, if you're using the VS project file from the library source code please check it carefully because it's not really maintained. The pre-built dlls are all built using command line tools and the makefiles included.


Torsten Andre2 wrote:

I'm having trouble concerning pthread_join as described in this [1]
posting. A "thread A" endlessly waits for an already ended "thread B" which
called "return NULL" or "pthread_exit(NULL)" (tried both). Sometimes it
seems if you wait long enough thread A passes the pthread_join statement,
though not always. Unfortunately I haven't been able to find anything in
the mail archive, though I am sure that this has been covered before.

Thread B hangs while calling longjmp (sp->start_mark, exception) in
ptw32_throw.c. I have read about the different styles to cleanup, but I
have to admit that currently I don't understand what they are about. All
that matters is that I get pthreads to execute properly at the moment.

I downloaded pthreads 2.8.0 source code and use Visual Studio 2008
Professional C++  to compile it using Win32-Debug settings on a Windows
Server 2008 x64 system. I haven't changed any settings of the VC++
project . The program calling pthread functions is written in C++. Besides
using the source code without any alterations, I also tried to use the
binary dll versions VC2 and VCE2. Both dll's did not solve the problem.

In [1] Ross states the problem may be another dllmain being called. Though
I don't believe that's the problem in my case, I don't define any other
dllmains but the one in Pthreads. Most probably, I guess, the problem is a
wrong defined symbol or something related.

Can someone please give me a hint how to get pthread to work properly? Any
help is highly appreciated. Thank you.



Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]