This is the mail archive of the mailing list for the pthreas-win32 project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

RE: Linking Issue,

Hi Sinan,

I really appreciate your reply.
Thanks very much. I think you are on the right track, but I don't think
that's quite it.

I have tried altering the -lpthreadGC2d by specifying the whole name of the
file, I have tried a few combinations. If I specify the library incorrectly
then I get a file not found error, which makes perfect sense. In my case,
and I could be wrong, I suspect that I am specifying the file correctly, but
that a leading underscore is being omitted for some reason.

Dumpbin on libpthreadGC2d.a indicates that the symbol being exported from
the library is '_pthread_create', whilst my code is trying to link
'pthread_create'. Somehow I am missing a leading underscore '_'.

This could be a c / c++ issue, but I have tried using extern "C" { #include
<pthread.h> } which does not help. There is something simple I am missing
with the naming of the symbols.


-----Original Message-----
[] On Behalf Of Sinan KAYA
Sent: 08 February 2007 03:32 PM
To: Craig Main;
Subject: RE: Linking Issue,

This is a compiler specific problem.Check out gcc documentation on how
to use it.

You use -l switch to link a library against a project. You need
something like

gcc .... -lpthreadGC2d 

Note that you omit lib in front of the library file and you can also
tell the compiler where to find the library by "-L" switch


-----Original Message-----
[] On Behalf Of Craig Main
Sent: Thursday, February 08, 2007 3:05 PM
Subject: Linking Issue,


I had really hoped to solve this problem by searching the list archive,
sorry for the question, but I am struggling.
I am sure this is a simple one.

I am using MinGW to compile and use pthreads.
I have built libpthreadGC2d.a and libpthreadGC2.a

I cannot seem to link the built library to my c++ application.
With -DPTW32_STATIC_LIB I receive undefined reference 'pthread_create',
without the define I receive undefined reference '__imp_pthread_create'

Is this a common problem?


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]