This is the mail archive of the mailing list for the libc-ports project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Add CFI information for MIPS assembly sources

On Fri, 8 Feb 2013, Maciej W. Rozycki wrote:

>  However it should be possible to wrap the macros into other ones by using 
> a different name.  This way the public macros would remain intact (yes, I 
> do have a concern as to the consistency of <sys/asm.h> vs <asm/asm.h> -- 
> they share a common ancestor, they provide abstract definitions that have 
> nothing to do specifically with userland or Linux kernel code and are both 
> meant to serve the same purpose, so the fewer divergences the better), 
> e.g.
> #define _LIBC_LEAF(symbol)	\
>   LEAF (symbol)			\
>   cfi_startproc
> (or perhaps call it _CFI_LEAF instead?).  What do you think?  Likewise the 
> others, and...

I don't think having yet more macros for start and end of functions would 
be an improvement; it seems clearly better for functions to use END where 
possible, in particular, and that's in both sys/asm.h and sysdep.h (and 
while the definitions are such that the one in sysdep.h would take 
precedence if both are included, having different definitions of the same 
macro in those two headers would seem just too confusing).

Joseph S. Myers

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]