This is the mail archive of the mailing list for the glibc project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

compiling glibc 2.9 with a new gcc - inlining failed in call to âsyslogâ

I tried to compile glibc

export CFLAGS="-O2"
../glibc-2.9-20081201/configure --prefix=/home/silvio/data/glibc/glibc-install 

and got the following error:

gcc ../sysdeps/unix/sysv/linux/syslog.c -c -std=gnu99 -fgnu89-inline -O2 -Wall 
-Winline -Wwrite-strings -fmerge-all-constants -Wstrict-prototypes   -
fexceptions   -I../include -I/home/silvio/data/mapa/glibc/glibc-build-loc/misc 
-I/home/silvio/data/mapa/glibc/glibc-build-loc -I../sysdeps/x86_64/elf -
I../nptl/sysdeps/unix/sysv/linux/x86_64 -I../sysdeps/unix/sysv/linux/x86_64 -
I../sysdeps/unix/sysv/linux/wordsize-64 -I../nptl/sysdeps/unix/sysv/linux -
I../nptl/sysdeps/pthread -I../sysdeps/pthread -I../sysdeps/unix/sysv/linux -
I../sysdeps/gnu -I../sysdeps/unix/common -I../sysdeps/unix/mman -
I../sysdeps/unix/inet -I../nptl/sysdeps/unix/sysv -I../sysdeps/unix/sysv -
I../sysdeps/unix/x86_64 -I../nptl/sysdeps/unix -I../sysdeps/unix -
I../sysdeps/posix -I../sysdeps/x86_64/fpu -I../nptl/sysdeps/x86_64 -
I../sysdeps/x86_64 -I../sysdeps/wordsize-64 -I../sysdeps/ieee754/ldbl-96 -
I../sysdeps/ieee754/dbl-64 -I../sysdeps/ieee754/flt-32 -I../sysdeps/ieee754 -
I../sysdeps/generic/elf -I../sysdeps/generic -I../nptl  -I.. -I../libio -I. -I 
/lib/modules/2.6.28-gentoo-r1-diffraction/build/include -D_LIBC_REENTRANT -
include ../include/libc-symbols.h       -o /home/silvio/data/mapa/glibc/glibc-
build-loc/misc/syslog.o -MD -MP -MF /home/silvio/data/mapa/glibc/glibc-build-
loc/misc/syslog.o.dt -MT /home/silvio/data/mapa/glibc/glibc-build-
../misc/syslog.c: In function â__vsyslog_chkâ:
../misc/syslog.c:123: sorry, unimplemented: inlining failed in call to 
âsyslogâ: function body not available
../misc/syslog.c:155: sorry, unimplemented: called from here
make[2]: *** [/home/silvio/data/mapa/glibc/glibc-build-loc/misc/syslog.o] 
Error 1
make[2]: Leaving directory 
make[1]: *** [misc/subdir_lib] Error 2
make[1]: Leaving directory `/home/silvio/data/mapa/glibc/glibc-2.9-20081201'
make: *** [all] Error 2

there are a few guys who seem to have a similar problem

This post is German
	same error
	so he changed syslog() to  __syslog()
	in misc/syslog.c:155
	and got
	an other compillation error:
	readlink_chk.c:28: error: conflicting types for â__readlink_chkâ
	../posix/bits/unistd.h:124: error: previous declaration of â__readlink_chkâ
i can confirm this.

I tried it with gcc-4.3.3 and 4.2.4 on a gentoo system amd64 as none root.

Attachment: signature.asc
Description: This is a digitally signed message part.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]