This is the mail archive of the libc-alpha@sourceware.org mailing list for the glibc project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [v2, with help] Re: run one test


"Carlos O'Donell" <carlos@redhat.com> writes:
> Bikeshed. Suggest "onecheck" alias given that 'make test' is the same
> as 'make check.'

Can add.  I was thinking we already have "make nss/tests" and "make
tests", we call them "tests" and "testsuite", and "make check" is just a
convenience target:

  # Support the GNU standard name for this target.
  .PHONY: check
  check: tests

Or we could call it "make test" (note singular) but I suspect this would
be confusing, and "make check" (note singular!) vs "make checks".


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]