This is the mail archive of the
mailing list for the glibc project.
Re: [PATCH] sysdeps/riscv/start.S: rename .Lload_gp to load_gp (bug 24376)
- From: Zack Weinberg <zackw at panix dot com>
- To: Andreas Schwab <schwab at suse dot de>
- Cc: Florian Weimer <fw at deneb dot enyo dot de>, GNU C Library <libc-alpha at sourceware dot org>, Palmer Dabbelt <palmer at sifive dot com>
- Date: Tue, 24 Sep 2019 10:02:44 -0400
- Subject: Re: [PATCH] sysdeps/riscv/start.S: rename .Lload_gp to load_gp (bug 24376)
- References: <firstname.lastname@example.org> <email@example.com> <firstname.lastname@example.org> <CAKCAbMhoC0XuoE-UToQmxPK-v8J4DBdBQa=QT3J7ePaDhK9fBw@mail.gmail.com> <email@example.com>
On Tue, Sep 24, 2019 at 9:32 AM Andreas Schwab <firstname.lastname@example.org> wrote:
> On Sep 24 2019, Zack Weinberg <email@example.com> wrote:
> > On Tue, Sep 24, 2019 at 9:23 AM Andreas Schwab <firstname.lastname@example.org> wrote:
> >> On Sep 24 2019, Florian Weimer <email@example.com> wrote:
> >> >
> >> > Perhaps use startup_load_gp instead, so that it's less ambiguous in
> >> > the debugging information?
> >> It's a local label, so no conflict possible.
> > That's not what he was saying.
> That's because I said that.
Yes, the issue is that your response does not address his concern.