This is the mail archive of the
mailing list for the glibc project.
Re: [PATCH] sysdeps/riscv/start.S: rename .Lload_gp to load_gp (bug 24376)
- From: Florian Weimer <fw at deneb dot enyo dot de>
- To: Andreas Schwab <schwab at suse dot de>
- Cc: libc-alpha at sourceware dot org, Palmer Dabbelt <palmer at sifive dot com>
- Date: Tue, 24 Sep 2019 15:20:10 +0200
- Subject: Re: [PATCH] sysdeps/riscv/start.S: rename .Lload_gp to load_gp (bug 24376)
- References: <email@example.com>
* Andreas Schwab:
> Renaming the symbol keeps the label in the symbol table as a normal local
> label, so that `objdump -d' can pick it up as an anchor.
> [BZ #24376]
> * sysdeps/riscv/start.S (load_gp): Rename from .Lload_gp, all uses
Perhaps use startup_load_gp instead, so that it's less ambiguous in
the debugging information?