This is the mail archive of the libc-alpha@sourceware.org mailing list for the glibc project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [PATCH] Don't build libnsl for new architectures


On Tue, Aug 14, 2018 at 6:38 AM, Andreas Schwab <schwab@suse.de> wrote:
> This makes it possible to exclude a library depending on the minimum
> shlib version.

This seems like a good mechanism to have in general, but for libnsl
specifically, I wonder if we should continue to install a stub library
(an .a library only, containing a single object file that defines no
symbols, would be the safest) for the sake of Makefiles that may have
-lnsl hardcoded.

zw


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]