This is the mail archive of the mailing list for the glibc project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: RFC: requiring GCC >= 4.7 to build glibc

On 20 Aug 2015 13:51, Joseph Myers wrote:
> For glibc 2.21 we increased the minimum GCC version for building glibc to 
> 4.6.  There's one major GCC release a year, so the correspondingly old 
> version for glibc 2.23 would be GCC 4.7.  What do people think about 
> increasing the minimum version requirement?

i'd like to see the diff (not exact, but at least get an idea).
the bullet points below don't seem terribly compelling to me.

> * Being able to assume __atomic_* are supported by the compiler if 
> desired.

do we actually get that ?  not all arches expand these as insns but
to external calls to libatomic.  unless we're ok with libc/libpthread
linking against libatomic ?

> * When using pragmas to disable -Wmaybe-uninitialized warnings, no need to 
> have conditionals to disable -Wuninitialized instead for 4.6 
> (-Wmaybe-uninitialized was added in 4.7).

we could use -Wno-error for gcc-4.6 too ...

> * More C11 support, so we no longer need to XFAIL some conform/ tests and 
> could use the new features in glibc if desired.

shouldn't we already be handling this and not XFAIL-ing when the compiler
is new enough ?

Attachment: signature.asc
Description: Digital signature

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]