This is the mail archive of the
mailing list for the glibc project.
Re: RFC: requiring GCC >= 4.7 to build glibc
- From: "H.J. Lu" <hjl dot tools at gmail dot com>
- To: Joseph Myers <joseph at codesourcery dot com>
- Cc: GNU C Library <libc-alpha at sourceware dot org>
- Date: Thu, 20 Aug 2015 06:53:45 -0700
- Subject: Re: RFC: requiring GCC >= 4.7 to build glibc
- Authentication-results: sourceware.org; auth=none
- References: <alpine dot DEB dot 2 dot 10 dot 1508201344140 dot 30940 at digraph dot polyomino dot org dot uk>
On Thu, Aug 20, 2015 at 6:51 AM, Joseph Myers <email@example.com> wrote:
> For glibc 2.21 we increased the minimum GCC version for building glibc to
> 4.6. There's one major GCC release a year, so the correspondingly old
> version for glibc 2.23 would be GCC 4.7. What do people think about
> increasing the minimum version requirement?
> Benefits include:
> * Being able to assume __atomic_* are supported by the compiler if
> * When using pragmas to disable -Wmaybe-uninitialized warnings, no need to
> have conditionals to disable -Wuninitialized instead for 4.6
> (-Wmaybe-uninitialized was added in 4.7).
> * More C11 support, so we no longer need to XFAIL some conform/ tests and
> could use the new features in glibc if desired.
No problem on i386, x86-64 and x32.