This is the mail archive of the libc-alpha@sourceware.org mailing list for the glibc project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [PATCH] Require bison 2.7 or newer for regenerating intl/plural.y


On 11 December 2014 at 17:35, Joseph Myers <joseph@codesourcery.com> wrote:
> On Thu, 11 Dec 2014, Will Newton wrote:
>
>> The merge of the latest gettext code introduced changes to the yacc
>> parser source that are incompatible with versions of bison older
>> than 2.7. Add a configure check for the appropriate versions and
>> document the requirement in INSTALL.
>>
>> ChangeLog:
>>
>> 2014-12-11  Will Newton  <will.newton@linaro.org>
>>
>>       * INSTALL: Document that we require bison 2.7 or above.
>
> INSTALL is a generated file.  You need to update manual/install.texi then
> regenerate INSTALL (with makeinfo 4.x).

Thanks for pointing that out. I tried rebuilding INSTALL but actually
it seems to require texinfo 4.7 (4.5 has no --plaintext option, 5.1
seems to reformat things a bit). I'll send a patch for that too.

-- 
Will Newton
Toolchain Working Group, Linaro


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]