This is the mail archive of the
mailing list for the glibc project.
[PING][PATCH] Inline useless nested function mi_arena.
- From: OndÅej BÃlka <neleai at seznam dot cz>
- To: Carlos O'Donell <carlos at redhat dot com>
- Cc: libc-alpha at sourceware dot org
- Date: Tue, 20 May 2014 17:26:00 +0200
- Subject: [PING][PATCH] Inline useless nested function mi_arena.
- Authentication-results: sourceware.org; auth=none
- References: <20140226214924 dot GA10204 at domone dot podge> <530EDAE7 dot 4050002 at redhat dot com> <20140305091532 dot GC6031 at domone dot podge>
On Wed, Mar 05, 2014 at 10:15:32AM +0100, OndÅej BÃlka wrote:
> On Thu, Feb 27, 2014 at 01:27:51AM -0500, Carlos O'Donell wrote:
> > On 02/26/2014 04:49 PM, OndÅej BÃlka wrote:
> > > Hi,
> > >
> > > I noticed a minor simplification in malloc_info, that nested function
> > > mi_arena looks useless as it gets called at only one site and I do not
> > > have to rename its argument. The resulting patch is big due of
> > > reindenting but is simple in principle.
> > >
> > > Is there any deep reason to keep it?
> > Having the per-arena malloc_info actions broken out into a
> > logical block makes the malloc_info code easier to read
> > and understand.
> Its block of code problem is how much is logical put it into separate
> > > * malloc/malloc.c (malloc_info): Inline mi_arena.
> > Make it a real function please? That way the generated debug
> > information is better.
> > Cheers,
> > Carlos.