This is the mail archive of the mailing list for the glibc project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [PATCH] Better distinguish between NaN/qNaN/sNaN.

On 03/05/2013 04:07 PM, Andreas Jaeger wrote:
> On 03/05/2013 08:31 PM, Thomas Schwinge wrote:
>> In preparation for adding tests with sNaN inputs later on.
>>     * math/basic-test.c (TEST_FUNC, TEST_TRUNC): Rename NaN_var to
>>     qNaN_var.  Fix a few strings, too.
>>     * math/ (nan_value): Rename to qnan_value.
>>     * math/ (%beautify): Adjust to that.
>>     * math/bits/mathcalls.h (nan): Refer to qNaN instead of NaN.
>>     * math/test-misc.c (main): Likewise.
>>     * sysdeps/ieee754/bits/nan.h (__nan_bytes, __nan_union): Rename
>>     to __qnan_bytes, and __qnan_union, respectively.
>>     * ports/sysdeps/mips/bits/nan.h (__nan_bytes, __nan_union):
>>     Likewise.
>>     * stdio-common/tstdiomisc.c (nanval, lnanval): Rename to qnanval,
>>     and lqnanval, respectively.
>>     * sysdeps/powerpc/bits/fenv.h: Fix usage of NaN/qNaN/sNaN.
>>     * sysdeps/powerpc/fpu/fenv_libc.h: Likewise.
>>     * sysdeps/powerpc/fpu/test-powerpc-snan.c (TEST_FUNC): Likewise,
>>     and rename NaN_var to qNaN_var, and SNaN_var to sNaN_var.
> this is fine,

Looks good to me also.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]