This is the mail archive of the
mailing list for the glibc project.
Re: Update Texinfo version requirement
- From: "Carlos O'Donell" <carlos at systemhalted dot org>
- To: "Joseph S. Myers" <joseph at codesourcery dot com>
- Cc: libc-alpha at sourceware dot org
- Date: Wed, 16 May 2012 11:37:40 -0400
- Subject: Re: Update Texinfo version requirement
- References: <Pine.LNX.firstname.lastname@example.org>
On Wed, May 16, 2012 at 10:44 AM, Joseph S. Myers
> The installation documentation claims the Texinfo version requirement
> is 3.12f or later; configure accepts 4.0 or later. ?The real minimum
> is certainly at least 4.2, because that's when @copying was
> I propose this patch changing the minimum to 4.5, which is the
> earliest version available from ftp.gnu.org and which I've confirmed
> does work. ?Regarding versions 4.2-4.4: 4.4 has documented as a
> language change "@value constructs are now expanded in the filename
> arguments to @include and @verbatiminclude.", which is a feature used
> by the glibc manual, so likely at least 4.4 is in fact required, and
> 4.5 was released four days after 4.4 (4 February 2003) so I don't
> think we need to worry about whether in fact 4.4 would also work for
> glibc; we could safely enough require a much more recent version, we
> just don't have any reason to do so.
> Tested x86. ?Note the INSTALL regeneration will also include some
> changes from other recent install.texi changes where INSTALL didn't
> get regenerated.
> 2012-05-16 ?Joseph Myers ?<email@example.com>
> ? ? ? ?* configure.in (makeinfo): Require version 4.5 or later. ?Allow
> ? ? ? ?versions 5 to 9.
> ? ? ? ?* configure: Regenerated.
> ? ? ? ?* manual/install.texi (texinfo): Increase version requirement to
> ? ? ? ?4.5 or later.
> ? ? ? ?* INSTALL: Regenerated.
This looks good to me. I'm using 4.13 or later on all the systems I have.