This is the mail archive of the
mailing list for the glibc project.
Re: [PATCH] Add --foreground option for nscd
On Wed, May 9, 2012 at 9:41 AM, Carlos O'Donell <email@example.com> wrote:
> Please use an enum. Magic constants are difficult to understand.
> Everyone understands:
> if (var == NAMED_STATE)
> Nobody understands:
> if (var <= 0)
> ... until they go and read the comment which describes two states at 1, and -1.
If you argue that the compiler does a better job with <= 0 then please
hide it behind a macro.
e.g. if (NAMED_STATE(var))