This is the mail archive of the libc-alpha@sourceware.org mailing list for the glibc project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Minimum Linux kernel version for glibc 2.17


On Wed, May 9, 2012 at 6:25 AM, Joseph S. Myers <joseph@codesourcery.com> wrote:
> I'm like to propose that the minimum Linux kernel version for glibc 2.17
> (the version to be released in December) is 2.6.16 (that is 2.6.16
> release, not 2.6.16-rcN).
>
> 2.6.16 was the first long-term-stable series of 2.6 kernels, and according
> to Wikipedia ceased to be maintained in July 2009; I don't think anything
> older than it is relevant for glibc 2.17. ?As well as allowing various
> __ASSUME_* conditionals to be cleaned up that could not be cleaned up if
> only 2.6.0 or 2.6.1 were required, requiring at least 2.6.16 would allow
> removing all the specific kernel version references in the README file.
>
> Any comments? ?(Suggestions that we require a kernel more recent than
> 2.6.16 are also welcome, but increasing the requirement beyond 2.6.16
> would require more care about the accuracy of the existing conditions in
> kernel-features.h; see bug 9894 regarding some versions there being
> inaccurate; Aurelien was at one point doing a general check of at least
> the more recent entries in kernel-features.h.)

This is fine with me, and in general I think it's a good idea.

I wouldn't want to go any higher than 2.6.16 though.

Cheers,
Carlos.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]