This is the mail archive of the mailing list for the glibc project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: NIS performance patches

Jeff Bastian wrote:
I finally managed to build a NIS server I can play with. I fired up 'ypbind -no-ping' on my client and it bound to the new server. Then I killed ypserv. The client broke:

Ignore my previous e-mail. The client works fine. It was a long day at work and I put a bad IP address in my yp.conf file...

So, now I have a yp.conf file with two servers: my test box and a production NIS server. I wrote a script that'll keep restarting ypbind until it picks my test server. Then I run ypwhich, ypmatch, and ypcat to verify it works.

I kill the ypserv daemon on the test server. I run ypwhich and it immediately rebinds to the production server.

I repeat the process, except when I kill ypserv, I try ypmatch on the client. This spits out an error message, but then rebinds to the production server and finds the record I'm trying to match.

I repeat the process again, except after killing ypserv, I try ypcat. This fails and does not cause the client to rebind.

This is all using glibc-2.3.2 and ypbind-1.12 as shipped with RedHat Enterprise Linux 3 with Update 1 plus the NIS patches.

I haven't looked at why ypcat fails to trigger a rebind yet. Hopefully I can find some time tomorrow afternoon to do that.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]