This is the mail archive of the mailing list for the glibc project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

Re: glibc 2.1.97 - make check fails

>>>>> ng  writes:

 > System information:
 > Linux laika 2.2.18pre18 #2 Tue Oct 31 22:38:30 CET 2000 i686 unknown
 > gcc version 2.95.2 19991024 (release)
 > binutils 2.10

 > All utilities are built from scratch, no patches applied.
 > They are built with gcc 2.95.2 and glibc 2.1.3 (also installed from source)
 > First make check dies here:

 > gcc -nostdlib -nostartfiles -o tst-dir  -Wl,-dynamic-linker=/lib/
 >  ../csu/crt1.o ../csu/crti.o `gcc --print-file-name=crtbegin.o` tst-dir.o  -Wl,-
 > rpath-link=..:../math:../elf:../dlfcn:../nss:../nis:../rt:../resolv:../crypt:../
 > linuxthreads ../ ../libc_nonshared.a -lgcc `gcc --print-file-name=crten
 > d.o` ../csu/crtn.o
 > GCONV_PATH=../iconvdata LC_ALL=C  ../elf/ --library-path ..:../math
 > :../elf:../dlfcn:../nss:../nis:../rt:../resolv:../crypt:../linuxthreads ./tst-di
 > r `pwd` "/posix" ".." tst-dir > tst-dir.out
 > make[1]: *** [tst-dir.out] Error 1
 > make[1]: Leaving directory `/usr/ports/linuxports/devel/glibc/glibc-2.1.97/posix
Could be a problem with building in the sourcedirectory :-(.

 > [/usr/ports/linuxports/devel/glibc/glibc-2.1.97]# cat posix/tst-dir.out 
 > cannot change to object directory: No such file or directory

 > No clue about that one.
 > I run make check again, and...

 > gcc -nostdlib -nostartfiles -o tst-chmod  -Wl,-dynamic-linker=/lib/
 >    ../csu/crt1.o ../csu/crti.o `gcc --print-file-name=crtbegin.o` tst-chmod.o  -
 > Wl,-rpath-link=..:../math:../elf:../dlfcn:../nss:../nis:../rt:../resolv:../crypt
 > :../linuxthreads ../ ../libc_nonshared.a -lgcc `gcc --print-file-name=c
 > rtend.o` ../csu/crtn.o
 > GCONV_PATH=../iconvdata LC_ALL=C  ../elf/ --library-path ..:../math
 > :../elf:../dlfcn:../nss:../nis:../rt:../resolv:../crypt:../linuxthreads ./tst-ch
 > mod  > tst-chmod.out
 > ./tst-chmod: no parameters
 > make[1]: *** [tst-chmod.out] Error 1
Same here.
 > No clue about that one either.
 > Again, I do make check, and...

 > make[1]: Leaving directory `/usr/ports/linuxports/devel/glibc/glibc-2.1.97/posix
 > gcc -nostdlib -nostartfiles -o test-lfs  -Wl,-dynamic-linker=/lib/
 >   ../csu/crt1.o ../csu/crti.o `gcc --print-file-name=crtbegin.o` test-lfs.o  -Wl
 > ,-rpath-link=..:../math:../elf:../dlfcn:../nss:../nis:../rt:../resolv:../crypt:.
 > ./linuxthreads ../ ../libc_nonshared.a -lgcc `gcc --print-file-name=crt
 > end.o` ../csu/crtn.o
 > GCONV_PATH=../iconvdata LC_ALL=C  ../elf/ --library-path ..:../math
 > :../elf:../dlfcn:../nss:../nis:../rt:../resolv:../crypt:../linuxthreads ./test-l
 > fs  > test-lfs.out
 > ./test-lfs: cannot write test string to large file: File too large
 > make[1]: *** [test-lfs.out] Error 1

 > No LFS support in my kernel perhaps?
Yes - but I thought the test was fixed to workaround this?

 > gcc -nostdlib -nostartfiles -o vismain  -Wl,-dynamic-linker=/lib/   ../csu/crt1.o ../csu/crti.o `gcc --print-file-name=crtbegin.o` vismain.o  -Wl,-rpath-link=..:../math:.:../dlfcn:../nss:../nis:../rt:../resolv:../crypt:../linuxthreads ../ ../libc_nonshared.a -lgcc `gcc --print-file-name=crtend.o` ../csu/crtn.o
 > GCONV_PATH=../iconvdata LC_ALL=C ../elf/ --library-path ..:../math:.:../dlfcn:../nss:../nis:../rt:../resolv:../crypt:../linuxthreads ./vismain  > vismain.out
 > Timed out: killed the child process
 > make[1]: *** [vismain.out] Error 1
 > make[1]: Leaving directory `/usr/ports/linuxports/devel/glibc/glibc-2.1.97/elf'
 > [/usr/ports/linuxports/devel/glibc/glibc-2.1.97]# cat elf/vismain.out
 > `.protected' seems to be handled correctly, good!

 > No clue about that one either.
binutils 2.10 doesn't handle everything correctly - it passes the
first test and then goes into an endless loop -> upgrade to HJ's
version or to current CVS.
 > Make install worked fine, but I didn't really have to guts to install it
 > as a system library.

 Andreas Jaeger
  SuSE Labs

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]