This is the mail archive of the mailing list for the glibc project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

Re: glibc-2.0.95 causes ls -al & ps -aux to segfault.

Ok, this is what I get when I set LD_LIBRARY_PATH to /tmplib/lib, and
then run:

/tmplib/lib/ /bin/ps 

[This segfaults].

Upon doing a gdb /bin/ps core I get the following:

warning: core file may not match specified executable file.
Core was generated by `/tmplib/lib/ /bin/ps ux'.
Program terminated with signal 11, Segmentation fault.
Reading symbols from /lib/ debugging symbols found)...done.
Reading symbols from /tmplib/lib/
Reading symbols from /tmplib/lib/
Reading symbols from /tmplib/lib/
#0  0x40091574 in find_transition (timer=902212685) at tzfile.c:393
393       if (num_transitions == 0 || timer < transitions[0])
(gdb) p num_transitions
$1 = 101
(gdb) p timer
$2 = 902212685
(gdb) p transitions[0]
$3 = 83907072

I don't know if that does you any good.  It seems like a weird place
to die when doing a ps.

Any ideas on how I should proceed?

How do I use gdb to load an executable, with a different set of
shared libraries?  [I've tried setting the environment, and also
having it run /tmplib/lib/, but it complains about

In any case, if I run /tmplib/lib/ /bin/ls -al,
it segfaults in the exact same spot.

[here's a backtrace for this case..]

(gdb) bt
#0  0x40084574 in find_transition (timer=894735004) at tzfile.c:393
#1  0x40084612 in __tzfile_compute (timer=894735004, use_localtime=1, 
    leap_correct=0xbffff664, leap_hit=0xbffff668, tp=0x400e1578)
    at tzfile.c:426
#2  0x40083b2b in __tz_convert (timer=0xbffff6a8, use_localtime=1, 
    tp=0x400e1578) at tzset.c:616
#3  0x4007ff51 in localtime (t=0xbffff6a8) at localtime.c:48

Let me know if there's anything I can do.

I have to go to work, so I'll start looking at source tonight or


> >>>>> bfaber  writes:
> >> Description:
>  > 	Compile glibc-2.0.95 with either gcc-2.8.1 or egcs-2.91.50,
>  >         and the binaries do not always work.
> Was `make check' successful?  Do you consider this as a compiler or a
> glibc2 bug?
> >> How-To-Repeat:
>  > 	Try to use the 'ls' that comes with redhat 5.0
> >> Fix:
>  > 	No idea.  To many things start segfaulting.
> Can I you localize the problem with gdb/strace?
> Is this a problem of ls in general or of `ls -l'?  In that case the
> lookup of user/group from /etc/passwd might be somehow broken.  What
> does /etc/nsswitch.conf look like?
> Andreas
> -- 
>  Andreas Jaeger
>   for pgp-key finger

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]