This is the mail archive of the mailing list for the Kawa project. See the Kawa home page for more information.

[Date Prev][Date Next][Thread Prev][Thread Next]
[Date Index] [Subject Index] [Author Index] [Thread Index]

Re: another macro problem


I did some more testing and I think the problem has something to do
with the record facility. Namely,

1. I fixed the problem with AWT/Swing methods: in general, if class <A>
defines method m, and class <B> inherits from A,
primitive-virtual-method must be called with <A> and "m", not <B> and
"m" (this is maybe obvious, but I thought it didn't matter as long as
m was visible in class <B>).

2. I tried with a functional version of `toplevel' instead of the
macro one; I also tried with `define-syntax' instead of `defmacro' but
without success.

3. Just to repeat, if I type in Kawa's top repl something close to the
expansion of a call to `toplevel' (the only difference is that I used
global definitions instead of a `let*'), it works. However, if I call
`toplevel', Kawa complains that it cannot find class `widget'; I use
variable `widget' to store the record type of name "widget" in it, but
I don't know of any class of that name.