This is the mail archive of the
mailing list for the GDB project.
Re: [RFC] "actionpoints"?
- From: Joel Brobecker <brobecker at adacore dot com>
- To: Stan Shebs <stan at codesourcery dot com>
- Cc: gdb at sourceware dot org
- Date: Mon, 18 Jan 2010 10:43:48 +0400
- Subject: Re: [RFC] "actionpoints"?
- References: <4B5106CB.email@example.com>
> One of the issues that has come up regularly in our tracepoint work
> is what GDB's messages to the user should say when they are
> referring to various combinations of tracepoints and breakpoints.
I like the idea of having a term that means either breakpoint/watchpoint/
tracepoint, etc. How about "eventpoint"? "actionpoint" sounds OK to me too.
We can officially document that term to explain to the user what it
means and start using it in our error messages. I would also like us
to start using it in lieu of "point", or "*point" as I'm starting to
see. "point" has been used in gdbserver for a while, and might be
already established enough to be understandable, but I just find
that it always slows me down when I read this term, it's never fluid.
"eventpoint" or "actionpoint" would be better.
I don't think we should change all the user interface (eg: info
breakpoints") where it is already clear what the output is about.
If it's about breakpoints only, we should continue using the more
precise term of "breakpoint", etc.
However, error or informational messages could be easier to read,
IMO, if we used a standard term instead if
breakpoint/watchpoint/tracepoint or even just "point".
Incidentally, there is a target_ops routine "to_can_use_hw_breakpoint"
which is meant to be used to query the target about support for any
of the actionpoint/eventpoint kinds. The purpose of this routine would
be clearer if renamed to "to_can_use_hw_eventpoint".
Did I mention that I'm partial to "eventpoint"? ;-) I think it's because
it's the terminology used on VxWorks, but I am not sure. In any case,
actionpoint source just as nice, and either is a fine choice to me.