This is the mail archive of the gdb@sourceware.org mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

SYMFILE_VERBOSE


Random minor question of the day:
Is SYMFILE_VERBOSE misnamed (and/or misused) ?

symfile.c has this:

static void
symbol_file_add_main_1 (char *args, int from_tty, int flags)
{
  const int add_flags = SYMFILE_MAINLINE | (from_tty ? SYMFILE_VERBOSE : 0);
  symbol_file_add (args, add_flags, NULL, flags);


"from_tty" has a specific connotation which doesn't always just mean
"be chatty", and converting it to the name "VERBOSE" might cause
confusion given that there's also info_verbose, and there are places
of code that test "from_tty || info_verbose".  Plus in
symbol_file_add_with_addrs_or_offsets it means more than just "be
chatty":

  if ((have_full_symbols () || have_partial_symbols ())
      && mainline
      && from_tty
      && !query (_("Load new symbol table from \"%s\"? "), name))
    error (_("Not confirmed."));


 It's not a problem today, per se, just wondering about down the road ...

OOC, was SYMFILE_FROM_TTY considered and rejected?


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]