This is the mail archive of the
mailing list for the GDB project.
[rfc] ``pc'' -> resume_addr?
- From: Andrew Cagney <ac131313 at cygnus dot com>
- To: gdb at sources dot redhat dot com
- Date: Thu, 11 Apr 2002 16:38:15 -0400
- Subject: [rfc] ``pc'' -> resume_addr?
GDB, in a number of places, refers to the ``pc'' - PC_REGNUM, frame->pc,
read_pc(), write_pc(), ...
I think this name choice was unfortunate. It is too easy for a
developer to confuse ``pc'' with the hardware ``pc''.
With this in mind, I'd like to propose a GDBspeak ``resume_addr''. It
is the address of the first instruction that will be executed when the
thoughts? better names?