This is the mail archive of the gdb-patches@sourceware.org mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [PATCH v3 3/4] Introduce field_unsigned


On 7/9/19 4:24 PM, Tom Tromey wrote:

>    void field_fmt_int (int width, ui_align align, const char *fldname,
>  		      int value);
> +  /* Like field_int, but print an unsigned value.  */
> +  void field_unsigned (const char *fldname, ULONGEST value);

FWIW, offhand the naming looks a bit surprising to me.

Given the existence of "field_int", I'd expect "unsigned" to print an
unsigned (int), not a ULONGEST.

(I was initialize surprised it wasn't called field_uint, like the
ui_out_field_uint function that is removed by this patch, until I
realized this works with a ULONGEST.)

To output a ULONGEST, I'd expect the method to be called field_ulongest.

Is your plan to rename field_int to field_signed, perhaps?

Thanks,
Pedro Alves


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]