This is the mail archive of the
mailing list for the GDB project.
Re: [PATCH/RFC] Refactor gdb.reverse/insn-reverse.c
On 01/26/2017 10:39 AM, Luis Machado wrote:
On 01/25/2017 04:28 PM, Yao Qi wrote:
On 17-01-25 12:11:01, Luis Machado wrote:
That is a reasonable assessment. insn-reverse.[c|exp] is redundant
would benefit from renaming too.
The support in "insn-support-<arch>.c means support for a set of
instructions for this particular subsystem of gdb, therefore why i
that name. Thinking about it further, instruction decoding support is
basis/foundation of reverse debugging, without which things would not
properly. But i may be overthinking. :-)
Every test is about testing some sort of support. Breakpoint test is
about breakpoint support, tracepoint test is about tracepoint support.
We don't have to explicitly mention "support" in the test case name,
It is easy to relate "insn-reverse-<arch>.c" to "insn-reverse.c".
If you think "reverse" is redundant, "insn.c" and "insn-<arch>.c" is
acceptable to me too.
It is not terribly important. I've reverted to the original name
(insn-reverse-<arch>.c), updated things to mention the new name and
pushed this as 8b00c176168dc7b0d78d0dc1f7d42f915375dc4a.
Thanks for reviewing,
Forgot to effectively add the files. I'll fix this in a bit.