This is the mail archive of the gdb-patches@sourceware.org mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [PATCH 09/30] Introduce interruptible_select


On 16-03-18 03:18 PM, Pedro Alves wrote:
> +int
> +interruptible_select (int n,
> +		      fd_set *readfds, fd_set *writefds, fd_set *exceptfds,
> +		      struct timeval *timeout)
> +{
> +  fd_set my_readfds;
> +  int fd;

Just a nit.  For clarity, you could name this variable "quit_fd" instead of "fd".


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]