This is the mail archive of the
mailing list for the GDB project.
Re: [PATCH 4/4] compile: New 'compile print'
- From: Eli Zaretskii <eliz at gnu dot org>
- To: Jan Kratochvil <jan dot kratochvil at redhat dot com>
- Cc: gdb-patches at sourceware dot org, pmuldoon at redhat dot com
- Date: Fri, 27 Mar 2015 10:18:43 +0300
- Subject: Re: [PATCH 4/4] compile: New 'compile print'
- Authentication-results: sourceware.org; auth=none
- References: <20150326205727 dot 28223 dot 54648 dot stgit at host1 dot jankratochvil dot net> <20150326205752 dot 28223 dot 24230 dot stgit at host1 dot jankratochvil dot net>
- Reply-to: Eli Zaretskii <eliz at gnu dot org>
> From: Jan Kratochvil <firstname.lastname@example.org>
> Cc: Phil Muldoon <email@example.com>
> Date: Thu, 26 Mar 2015 21:57:52 +0100
> It is planned the existing GDB command 'print' will be able to evaluate its
> expressions using the compiler. There will be some option to choose between
> the existing GDB evaluation and the compiler evaluation. But as an
> intermediate step this patch provides the expression printing feature as a new
> I can imagine it could be also called 'maintenance compile print' as in the
> future one should be able to use its functionality by the normal 'print'
I suggest a different name for this command. Unfortunately, "eval" is
already taken, but perhaps "parse" or "parse-eval"? Or maybe a new
switch to "print"? "compile print" sounds awkward and unintuitive to
> + add_cmd ("print", class_obscure, compile_print_command,
> + _("\
> +Evaluate a EXPR with the compiler and print result.\n\
Suggest to drop the "a" part, it just makes this sentence harder to
> +The expression may be specified in one line, e.g.:\n\
"on the same line as the command" sounds more clear to me.
Otherwise, the documentation parts are OK.