This is the mail archive of the
mailing list for the GDB project.
Re: [RFC] [PATCH] Provide the ability to write the frame unwinder in Python
- From: Doug Evans <dje at google dot com>
- To: Alexander Smundak <asmundak at google dot com>
- Cc: Andy Wingo <wingo at igalia dot com>, gdb-patches <gdb-patches at sourceware dot org>
- Date: Wed, 18 Mar 2015 16:25:27 -0700
- Subject: Re: [RFC] [PATCH] Provide the ability to write the frame unwinder in Python
- Authentication-results: sourceware.org; auth=none
- References: <CAHQ51u7NUoQ8w9c5mc-Eiz05b1Nub6zqj_Ne7vfgWb5EP9_X8w at mail dot gmail dot com> <21714 dot 40641 dot 510825 dot 30998 at ruffy2 dot mtv dot corp dot google dot com> <CAHQ51u5_ViLaEmv9e43R-wzuWw8dwNkb-2XgCRy5ELQq5FUAWg at mail dot gmail dot com> <54E71694 dot 1080304 at redhat dot com> <CAHQ51u75+9HYAVJXYNQa0gTnQtYKEgmSkyAhAPYp-y4HGtXssg at mail dot gmail dot com> <CAHQ51u6UZ7A47rpGgX0QGeYSTCz1eo_3jWHc=q2ZX3YhqcJ6iQ at mail dot gmail dot com> <87ioei31uj dot fsf at igalia dot com> <CAHQ51u4f+Vx7qXPm-KAAENOceaVogMbDMw6==N_nY+GrLr4Pgg at mail dot gmail dot com> <87d24p19tt dot fsf at igalia dot com> <54FD7DAA dot 7010603 at redhat dot com> <CAHQ51u7sUkGhkmvTaaO_Jo6Jn+kojfiMWHmc2=7OWHThAq6EKw at mail dot gmail dot com> <87twxrncld dot fsf at igalia dot com> <CAHQ51u60nHp1a2DXZ4srvRefyTtge1BUw7-=JuYqChHN_wUGyQ at mail dot gmail dot com> <87ioe1dvu2 dot fsf at igalia dot com> <CAHQ51u7KzQLSLC=QeLA=zd+TUkbbNzzndfeVLFWpjiR-pL8ang at mail dot gmail dot com> <87sid4atms dot fsf at igalia dot com> <CAHQ51u6=9BKf6YSTavbY7u_Mi6miKJ_Yo1QcaG=KsYtYzoWY_Q at mail dot gmail dot com>
On Tue, Mar 17, 2015 at 12:48 PM, Alexander Smundak <email@example.com> wrote:
> IMHO we reached an agreement on API.
> I would really like the reviewers to express their opinions about the naming
> at this point. To summarize:
> * We need a name for the entity passed to a sniffer. This entity provides
> access to the registers of the frame being sniffed, and has factory methods
> to create instances returned by a sniffer.
> * We need a name for the entity returned by a sniffer.
> * Should the term 'sniffer' be used in the API and documentation describing
> implementing frame unwinding in GDB extensions?
I'm not sure I'm going to be of much help here.
I don't mind "sniffing" as the name of the act of deciding whether
a frame as recognized, and I do like "unwinder" as the name of
the object doing the sniffing. But then "sniffer" instead of
"unwinder" seems fine too.
Regarding the result of an unwinder/sniffer,
If I approach this from the point of view of what's
easy to explain, it feels like the result of an Unwinder
is a Frame.
Would it make sense to speak of an Unwinder taking
an EphemeralFrame as input and returning a Frame as output?