This is the mail archive of the gdb-patches@sourceware.org mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

[PATCH 00/15] Refactor shared code in i386-{nat,low}.[ch]


Hi all,

This series refactors the shared code in i386-{nat,low}.[ch] into
a pair of new files, nat/i386-dregs.[ch].  The patches are in two
groups.  Group 1 removes the changes between the various files so
that the code to be shared is identical:

   1/15 - Whitespace changes
   2/15 - Remove unnecessary prototypes
   3/15 - Remove unused macro
   4/15 - Comment changes
   5/15 - Add a const
   6/15 - Merge printing code
   7/15 - Merge error handling
   8/15 - Rename maint_show_dr to debug_hw_points
   9/15 - Merge i386_update_inferior_debug_regs
  10/15 - Abstract i386_dr_low access

Group 2 moves all that identical code into the new files:

  11/15 - Rename functions and make nonstatic as necessary
  12/15 - Create nat/i386-dregs.h
  13/15 - Move macros from i386-{nat,low}.c to i386-{nat,low}.h
  14/15 - Create nat/i386-dregs.c
  15/15 - Buildsystem changes

Is this ok to commit?

Thanks,
Gary

--
http://gbenson.net/


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]