This is the mail archive of the gdb-patches@sourceware.org mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [RFC v2] Unnecessary argument METHOD to valops.c:find_oload_champ?


I apologize for the previous send; some magic gmail shortcut seems to
have sent it before I wanted to press the send button.

On Fri, Feb 28, 2014 at 12:33 PM, Doug Evans <dje@google.com> wrote:
>
> I'd collapse this into just a single assert:
>
>    gdb_assert ((fns_ptr != NULL) + (oload_syms != NULL) == 1).

Pushed the attached patch which addresses this.

> Btw, I see room for more cleanups.
>
> E.g., oload_method_static could use some TLC.
> - it's passed an enum for the method arg where we assume non-zero
> values are correct
> - IWBN to delete its method arg too
> - its result feels like it's intended to be true/false, but it's used
> as an integer
>   (rename function to oload_method_static_offset ?)
>
> I wouldn't make them part of the current patch, and feel free to pass.
> But since you're in the neighborhood ... :-)

Will take it up shortly.

Attachment: find_oload_champ_patch_v3.txt
Description: Text document


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]