This is the mail archive of the gdb-patches@sourceware.org mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

RE: [PATCH v4 01/13] vla: introduce new bound type abstraction adapt uses


Thanks for your review.

> -----Original Message-----
> From: gdb-patches-owner@sourceware.org [mailto:gdb-patches-owner@sourceware.org] On Behalf
> Of Joel Brobecker
> Sent: Wednesday, December 18, 2013 04:24 AM
> To: Agovic, Sanimir
> Cc: tromey@redhat.com; palves@redhat.com; xdje42@gmail.com; gdb-patches@sourceware.org;
> Boell, Keven
> Subject: Re: [PATCH v4 01/13] vla: introduce new bound type abstraction adapt uses
> 
> > 	* dwarf2read.c (read_subrange_type): Use struct bound_prop for
> > 	declaring high/low bounds and change uses accordingly. Call
> > 	create_range_type_1 instead of create_range_type.
> > 	* gdbtypes.c (create_range_type_1): New function.
> > 	(create_range_type): Convert bounds into struct bound_prop and pass
> > 	them to create_range_type_1.
> > 	* gdbtypes.h (struct bound_prop): New struct.
> > 	(create_range_type_1): New function prototype.
> > 	(struct range_bounds): Use struct bound_prop instead of LONGEST for
> > 	high/low bounds. Remove low_undefined/high_undefined and adapt all uses.
> > 	(TYPE_LOW_BOUND,TYPE_HIGH_BOUND): Adapt macros to refer to the static
> > 	part of the bound.
> > 	* parse.c (follow_types): Set high bound kind to BOUND_UNDEFINED.
> 
> Just a suggestion, which you may choose to ignore.
> 
> I think that the _1 suffix is usually used when the function performs
> the private portion of a more public routine.  But in this case,
> create_range_type_1 is meant to be a public routine, and the _1
> suffix is not very explicit.  IMO, what would be ideal would be to
> rename the current create_range_type into "create_static_range_type",
> and then make create_range_type_1 the new create_range_type. I checked
> the GDB tree, and there aren't that many calls to update. If people
> prefer, I can even take care of that myself once the patche series
> has gone in. Otherwise, another compromise solution is to rename
> create_range_type_1 to create_range_type_full (for instance).
> 
Sounds good to me. I will prepend a patch doing the 
create_range_type -> create_static_range_type thingy and use create_range_type
in this patch instead of create_range_type_1.

> > +/* Used to store a dynamic property.  */
> > +
> > +struct dynamic_prop
> > +{
> > +  /* Determine which field of the union dynamic_prop.data is used.  */
> > +  enum
> > +  {
> > +    PROP_UNDEFINED,
> > +    PROP_CONST,
> > +    PROP_LOCEXPR,
> > +    PROP_LOCLIST
> > +  } kind;
> > +
> > +  /* Storage for dynamic or static value.  */
> > +  union data
> > +  {
> > +    LONGEST const_val;
> > +    void *baton;
> > +  } data;
> 
> Would you mind documenting each enumeration and union field?
> 
Definitely, wired that I missed it. Thanks.

> > +#define TYPE_LOW_BOUND(range_type) \
> > +  TYPE_RANGE_DATA(range_type)->low.data.const_val
> > +#define TYPE_HIGH_BOUND(range_type) \
> > +  TYPE_RANGE_DATA(range_type)->high.data.const_val
> >  #define TYPE_LOW_BOUND_UNDEFINED(range_type) \
> > -   TYPE_RANGE_DATA(range_type)->low_undefined
> > +  (TYPE_RANGE_DATA(range_type)->low.kind == PROP_UNDEFINED)
> >  #define TYPE_HIGH_BOUND_UNDEFINED(range_type) \
> > -   TYPE_RANGE_DATA(range_type)->high_undefined
> > +  (TYPE_RANGE_DATA(range_type)->high.kind == PROP_UNDEFINED)
> > +#define TYPE_HIGH_BOUND_KIND(range_type) \
> > +  TYPE_RANGE_DATA(range_type)->high.kind
> > +#define TYPE_LOW_BOUND_KIND(range_type) \
> > +  TYPE_RANGE_DATA(range_type)->low.kind
> 
> For the record, I considered the idea of adding asserts in there,
> in order to get an internal error instead of an odd bug when accessing
> the wrong field.
>
Indeed, I have spent some time debugging just to figure out I passed the
wrong "type" to the macros.

> But this requires us making these macros read-only
> accessors, rather than read-write. A quick experiment showed that
> some units are using them to write some fields, and so we would need
> to audit that first. It's a desirable change on its own, IMO, regardless
> of whether we thinking adding the assert is desirable or not, but I don't
> want to put the burden on this patch series, which seems already quite
> sizeable on its own already.
> 
I agree here as well but I`d like to have this kind of refactoring's separated
from the patch series. Once the initial vla support is in I can have a closer look
at these macros.

> --
> Joel
Intel GmbH
Dornacher Strasse 1
85622 Feldkirchen/Muenchen, Deutschland
Sitz der Gesellschaft: Feldkirchen bei Muenchen
Geschaeftsfuehrer: Christian Lamprechter, Hannes Schwaderer, Douglas Lusk
Registergericht: Muenchen HRB 47456
Ust.-IdNr./VAT Registration No.: DE129385895
Citibank Frankfurt a.M. (BLZ 502 109 00) 600119052


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]